Why aren't my click tracking links working?

If you've received a message where click tracking links aren't appearing or aren't working, there are a few reasons as to why this might be.

Are You Viewing a Test?

Links are encoded at the point of your messages being sent to subscribers on your list.  If you're viewing a message you sent to yourself using the "Test" feature, you won't see a tracking link in the message.

Are You Viewing an HTML Message?

Clickable links in HTML messages are created using the hyperlink tool.  As opposed to a plain-text message where the URL as it's typed in is made clickable, like links on your website, whatever text you highlight to turn into a hyperlink is what your subscribers will see when they view the message.

As long as you've typed in a full URL address for the "Location" when you created the hyperlink, any clicks on it will still be tracked.

Is Click Tracking Turned On?

In the new message editor, Click Tracking is automatically enabled.

In the previous message editor, click Tracking is turned on or off for each message on an individual basis.  Go to the Messages section of your control panel and make sure click tracking is turned on for the message you're reviewing.



Did You Use Personalization?

As long as you are sending people to a web page that has AWeber analytics installed, using personalization fields is fine.

However, if you've placed a personalization field into the URL address of the page you're linking to, and you are linking to a page that does not have AWeber analytics installed, click tracking will not work. You'll need either to turn off click tracking, or remove the field in order for click tracking to work for the link.

For example, this address would not be trackable if you had not installed AWeber's analytics on example.com:

http://www.example.com/?{firstname_fix}
 

Did You Receive A Miscellaneous Error?

When you have a URL in your message, our system will review that URL and search the website for a variety of validations and errors. If the site is invalid, a notice would be provided. If you add in your hyperlink and receive a "Miscellaneous Error", that would occur because there is likely an issue with the validation of the site. This could be occurring from some of the scripts published to your site that does not allow us to validate the page.

 

Did You Type a Full URL?

In order for the system to recognize your addresses, they need to be entered properly, in full.

For example, the following would be tracked:

http://www.example.com


... but any of these would not:

www.example.com
example.com
example.com/about.htm
Have more questions? Submit a request
Powered by Zendesk